aboutsummaryrefslogtreecommitdiff
path: root/package/libgpg-error
diff options
context:
space:
mode:
Diffstat (limited to 'package/libgpg-error')
-rw-r--r--package/libgpg-error/0001-avoid-breakage-with-gcc-5.patch56
-rw-r--r--package/libgpg-error/Config.in42
-rw-r--r--package/libgpg-error/libgpg-error.hash2
-rw-r--r--package/libgpg-error/libgpg-error.mk16
4 files changed, 53 insertions, 63 deletions
diff --git a/package/libgpg-error/0001-avoid-breakage-with-gcc-5.patch b/package/libgpg-error/0001-avoid-breakage-with-gcc-5.patch
deleted file mode 100644
index 96dc569cb3..0000000000
--- a/package/libgpg-error/0001-avoid-breakage-with-gcc-5.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-Patch ported from Debian
-http://anonscm.debian.org/cgit/pkg-gnupg/libgpg-error.git/diff/?id=c3d7571
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
-
-
-From 91da4f5dbbc9d93975ef9753652a4e71719f9f27 Mon Sep 17 00:00:00 2001
-From: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
-Date: Mon, 16 Mar 2015 13:26:00 -0400
-Subject: [LIBGPG-ERROR PATCH] avoid breakage with gcc 5
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
- * src/Makefile.am: add -P to the C preprocessor when building
- mkerrcodes.h, to avoid a noisy intermediate pipeline.
-
---
-
-With gcc 5 without this patch, we see many errors like the following:
-
-gcc -I. -I. -o mkerrcodes ./mkerrcodes.c
-In file included from ./mkerrcodes.c:26:0:
-./mkerrcodes.h:9:5: error: expected expression before ‘,’ token
- { , "GPG_ERR_E2BIG" },
- ^
-./mkerrcodes.h:10:5: error: expected expression before ‘,’ token
- { , "GPG_ERR_EACCES" },
- ^
-
-This patch cleans up the generated mkerrcodes.h by making the
-intermediate stage clean for all the versions of gcc i tested (4.x and
-5).
-
-Debian-Bug-Id: 777374
-Signed-Off-By: Daniel Kahn Gillmor <dkg@fifthhorseman.net>
----
- src/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 99c2c53..f847a80 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -213,7 +213,7 @@ code-to-errno.h: Makefile mkerrnos.awk errnos.in
- # It is correct to use $(CPP). We want the host's idea of the error codes.
- mkerrcodes.h: Makefile mkerrcodes.awk $(gpg_extra_headers)
- $(AWK) -f $(srcdir)/mkerrcodes1.awk $(srcdir)/errnos.in >_$@
-- $(CPP) $(CPPFLAGS) $(extra_cppflags) _$@ | grep GPG_ERR_ | \
-+ $(CPP) $(CPPFLAGS) $(extra_cppflags) -P _$@ | grep GPG_ERR_ | \
- $(AWK) -f $(srcdir)/mkerrcodes.awk >$@
- -rm _$@
-
---
-2.1.4
-
diff --git a/package/libgpg-error/Config.in b/package/libgpg-error/Config.in
index 114e2b7ca5..4a667b47b3 100644
--- a/package/libgpg-error/Config.in
+++ b/package/libgpg-error/Config.in
@@ -1,7 +1,49 @@
+config BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS
+ bool
+ # see src/syscfg/
+ default y if \
+ BR2_aarch64 || BR2_aarch64_eb || BR2_arm || \
+ BR2_armeb || BR2_i386 || BR2_mips || \
+ BR2_mipsel || BR2_mips64 || BR2_mips64el || \
+ BR2_m68k || BR2_nios2 || BR2_powerpc || \
+ BR2_powerpc64 || BR2_powerpc64le || BR2_sh4 || \
+ BR2_sh4eb || BR2_sh4a || BR2_sh4aeb || \
+ BR2_sparc || BR2_sparc64 || BR2_x86_64
+
config BR2_PACKAGE_LIBGPG_ERROR
bool "libgpg-error"
+ depends on BR2_PACKAGE_LIBGPG_ERROR_ARCH_SUPPORTS
help
Libgpg-error is a small library with error codes and
descriptions shared by most GnuPG related software.
https://www.gnupg.org/related_software/libgpg-error
+
+config BR2_PACKAGE_LIBGPG_ERROR_SYSCFG
+ string
+ default "aarch64-unkown-linux-gnu" \
+ if BR2_aarch64 || BR2_aarch64_eb
+ default "arm-unknown-linux-gnueabi" \
+ if BR2_arm || BR2_armeb
+ default "i686-pc-linux-gnu" \
+ if BR2_i386
+ default "mips-unkown-linux-gnu" \
+ if BR2_mips || BR2_mipsel
+ default "mips64el-unkown-linux-gnuabi64" \
+ if BR2_mips64 || BR2_mips64el
+ default "m68k-unkown-linux-gnu" \
+ if BR2_m68k
+ default "nios2-unknown-linux-gnu" \
+ if BR2_nios2
+ default "powerpc-unkown-linux-gnu" \
+ if BR2_powerpc
+ default "powerpc64-unkown-linux-gnu" \
+ if BR2_powerpc64 || BR2_powerpc64le
+ default "sh4-unkown-linux-gnu" \
+ if BR2_sh4 || BR2_sh4eb || BR2_sh4a || BR2_sh4aeb
+ default "sparc-unkown-linux-gnu" \
+ if BR2_sparc
+ default "sparc64-unknown-linux-gnu" \
+ if BR2_sparc64
+ default "x86_64-pc-linux-gnu" \
+ if BR2_x86_64 \ No newline at end of file
diff --git a/package/libgpg-error/libgpg-error.hash b/package/libgpg-error/libgpg-error.hash
index 76aff5d751..7e06b91054 100644
--- a/package/libgpg-error/libgpg-error.hash
+++ b/package/libgpg-error/libgpg-error.hash
@@ -1,2 +1,2 @@
# Locally calculated after checking pgp signature
-sha256 fa6fbf315efa33a943751e3c4d04ea3d41ddf4bdee5727de3c0978277d52923b libgpg-error-1.12.tar.gz
+sha256 0939cd4bd9bc027ae24a8b05a698af962b5af3d7a34c1fea15279ea69ea27abc libgpg-error-1.23.tar.gz
diff --git a/package/libgpg-error/libgpg-error.mk b/package/libgpg-error/libgpg-error.mk
index 52b7058e81..b074ff610b 100644
--- a/package/libgpg-error/libgpg-error.mk
+++ b/package/libgpg-error/libgpg-error.mk
@@ -4,14 +4,18 @@
#
################################################################################
-LIBGPG_ERROR_VERSION = 1.12
+LIBGPG_ERROR_VERSION = 1.23
LIBGPG_ERROR_SITE = ftp://ftp.gnupg.org/gcrypt/libgpg-error
-LIBGPG_ERROR_LICENSE = LGPLv2.1+
-LIBGPG_ERROR_LICENSE_FILES = COPYING.LIB
+LIBGPG_ERROR_LICENSE = GPLv2+, LGPLv2.1+
+LIBGPG_ERROR_LICENSE_FILES = COPYING COPYING.LIB
LIBGPG_ERROR_INSTALL_STAGING = YES
LIBGPG_ERROR_CONFIG_SCRIPTS = gpg-error-config
-# we patch src/Makefile.am
-LIBGPG_ERROR_AUTORECONF = YES
-LIBGPG_ERROR_GETTEXTIZE = YES
+
+define LIBGPG_ERROR_FIX_CROSS_COMPILATION
+ cd $(@D)/src/syscfg && \
+ ln -s lock-obj-pub.$(call qstrip, $(BR2_PACKAGE_LIBGPG_ERROR_SYSCFG)).h \
+ lock-obj-pub.$(GNU_TARGET_NAME).h
+endef
+LIBGPG_ERROR_PRE_CONFIGURE_HOOKS += LIBGPG_ERROR_FIX_CROSS_COMPILATION
$(eval $(autotools-package))