aboutsummaryrefslogtreecommitdiff
path: root/package/systemd/Config.in
diff options
context:
space:
mode:
authorGravatar Yann E. MORIN <yann.morin.1998@free.fr>2018-08-05 10:46:19 +0200
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2018-08-05 12:04:58 +0200
commit8f4a224f3c7423b82893a0f3ecca96f93253303c (patch)
tree2124150ab29aff31745a1c540d420022048b6f20 /package/systemd/Config.in
parent340a09030445d2acffc18878c281539055a7aaf0 (diff)
downloadbuildroot-8f4a224f3c7423b82893a0f3ecca96f93253303c.tar.gz
buildroot-8f4a224f3c7423b82893a0f3ecca96f93253303c.tar.bz2
package/polkit: needs glibc
The recent bump of polkit introduced a version that now unconditionally uses glibc-specific functions from the getnetgrent() familly, which are not available on musl or uClibc-ng. Hide away polkit when the C library is not glibc. Propagate the dependency to packages that select polkit: udisks and systemd. For systemd, add a comment. Fixes: http://autobuild.buildroot.org/results/d78/d783e6db60b187aa591f4b0150c590ab3aa5252f/ (musl) http://autobuild.buildroot.org/results/ba5/ba5da960c70c765bee753a79b9ad2c10967d05d6/ (uclibc) [...] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Marek Belisko <marek.belisko@open-nandra.com> Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Cc: Artem Panfilov <apanfilov@spectracom.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Diffstat (limited to 'package/systemd/Config.in')
-rw-r--r--package/systemd/Config.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index c5a109675c..1cc0021b87 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -216,6 +216,7 @@ config BR2_PACKAGE_SYSTEMD_NETWORKD
config BR2_PACKAGE_SYSTEMD_POLKIT
bool "enable polkit support"
+ depends on BR2_TOOLCHAIN_USES_GLIBC # polkit
select BR2_PACKAGE_POLKIT
help
If enabled, systemd is built with polkit support and policy
@@ -225,6 +226,9 @@ config BR2_PACKAGE_SYSTEMD_POLKIT
http://wiki.freedesktop.org/www/Software/polkit/
+comment "polkit support needs a glibc toolchain"
+ depends on !BR2_TOOLCHAIN_USES_GLIBC
+
config BR2_PACKAGE_SYSTEMD_QUOTACHECK
bool "enable quotacheck tools"
help