aboutsummaryrefslogtreecommitdiff
path: root/package/mesa3d/Config.in
diff options
context:
space:
mode:
authorGravatar Yann E. MORIN <yann.morin.1998@free.fr>2019-10-26 16:53:24 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2019-10-27 10:00:29 +0100
commit55fc80260b504a9b05f9026f418cfb8af1f5efd6 (patch)
treea111a20d65dfd11c169c978b3cdb7af7ecf855d0 /package/mesa3d/Config.in
parent5ee815ab6a9a2f93f4260126b80aec3ba27e6598 (diff)
downloadbuildroot-55fc80260b504a9b05f9026f418cfb8af1f5efd6.tar.gz
buildroot-55fc80260b504a9b05f9026f418cfb8af1f5efd6.tar.bz2
packages: host gcc >= 4.8 is now guaranteed
... so we can drop all config options about it and previous versions. Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Cc: Peter Korsgaard <peter@korsgaard.com> Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com> Cc: Romain Naour <romain.naour@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/mesa3d/Config.in')
-rw-r--r--package/mesa3d/Config.in5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/mesa3d/Config.in b/package/mesa3d/Config.in
index 3b23467a12..d247f57846 100644
--- a/package/mesa3d/Config.in
+++ b/package/mesa3d/Config.in
@@ -23,7 +23,6 @@ config BR2_PACKAGE_MESA3D_NEEDS_ELFUTILS
config BR2_PACKAGE_MESA3D_LLVM
bool "llvm support"
depends on BR2_PACKAGE_LLVM_ARCH_SUPPORTS
- depends on BR2_HOST_GCC_AT_LEAST_4_8
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_8
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_INSTALL_LIBSTDCPP
@@ -32,10 +31,10 @@ config BR2_PACKAGE_MESA3D_LLVM
depends on BR2_USE_WCHAR # std::wstring
select BR2_PACKAGE_LLVM
-comment "llvm support needs a toolchain w/ wchar, threads, C++, gcc >= 4.8, host gcc >= 4.8, dynamic library"
+comment "llvm support needs a toolchain w/ wchar, threads, C++, gcc >= 4.8, dynamic library"
depends on BR2_PACKAGE_LLVM_ARCH_SUPPORTS
depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INSTALL_LIBSTDCPP || \
- !BR2_HOST_GCC_AT_LEAST_4_8 || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
+ !BR2_TOOLCHAIN_GCC_AT_LEAST_4_8 \
|| BR2_STATIC_LIBS || !BR2_USE_WCHAR
comment "llvm support needs a toolchain not affected by GCC bug 64735"