aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Fabrice Fontaine <fontaine.fabrice@gmail.com>2018-09-28 19:35:18 +0200
committerGravatar Peter Korsgaard <peter@korsgaard.com>2018-10-05 22:02:50 +0200
commitcea60ba7feb6044375bc1ce62a849a05bce17795 (patch)
tree35f6b3032f4946caf11ade2273c478c9ff2061bb
parentc5279179970a3b808b94e441ff150d1d655525f2 (diff)
downloadbuildroot-cea60ba7feb6044375bc1ce62a849a05bce17795.tar.gz
buildroot-cea60ba7feb6044375bc1ce62a849a05bce17795.tar.bz2
lua: fix dynamic library install
In 0002-shared-libs-for-lua.patch, revision number is used to set library name: TO_SOLIB = liblua.so.$(R) However, library is built using PKG_VERSION which is passed only during build step: $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $? As a result, dynamic library is not installed in staging or target paths since bump to lua 5.3.5 So, instead of replacing R by PKG_VERSION and passing this variable in all steps, simply update R to 5 Fixes: - http://autobuild.buildroot.net/results/28b6672188bb0082ac1467d3b45904880e3634f3 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Acked-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> (cherry picked from commit ca287f204426446fd782544131429030c4825f0e) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/lua/5.3.5/0003-fix-revision-number.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/package/lua/5.3.5/0003-fix-revision-number.patch b/package/lua/5.3.5/0003-fix-revision-number.patch
new file mode 100644
index 0000000000..ed2e0460eb
--- /dev/null
+++ b/package/lua/5.3.5/0003-fix-revision-number.patch
@@ -0,0 +1,31 @@
+Fix revision number
+
+In 0002-shared-libs-for-lua.patch, revision number is used to set
+library name:
+TO_SOLIB = liblua.so.$(R)
+
+However, library is built using PKG_VERSION which is passed only during
+build step:
+$(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
+
+As a result, dynamic library is not installed in staging or target paths
+since bump to lua 5.3.5
+
+So, instead of replacing R by PKG_VERSION and passing this variable in
+all steps, simply update R to 5
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -47,6 +47,6 @@
+
+ # Lua version and release.
+ V= 5.3
+-R= $V.4
++R= $V.5
+
+ # Targets start here.
+ all: $(PLAT)