aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Adam Duskett <aduskett@greenlots.com>2019-12-04 13:49:13 -0800
committerGravatar Thomas Petazzoni <thomas.petazzoni@bootlin.com>2019-12-06 23:45:31 +0100
commita7d117a7b8169f28b91e662ecdd52231da04e5fd (patch)
tree01d2a6deaa1f7e6ae3524427acb2cc9f8f0ad955
parent6ade587665ba0dbe851986af905c7fce2e593a02 (diff)
downloadbuildroot-a7d117a7b8169f28b91e662ecdd52231da04e5fd.tar.gz
buildroot-a7d117a7b8169f28b91e662ecdd52231da04e5fd.tar.bz2
package/spidermonkey: depends on host gcc >= 4.9
If GCC on the host is older than 4.9, during the configure stage an error is thrown such as: checking whether the host C compiler can be used... no ERROR: Only GCC 4.9 or newer is supported (found version 4.8.2). Depend on the host gcc version being >= 4.9 Fixes: http://autobuild.buildroot.net/results/192661452fd522bf46b23d5a7a522eb853a984bf Signed-off-by: Adam Duskett <aduskett@greenlots.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
-rw-r--r--package/spidermonkey/Config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/spidermonkey/Config.in b/package/spidermonkey/Config.in
index 284502f618..5f12110626 100644
--- a/package/spidermonkey/Config.in
+++ b/package/spidermonkey/Config.in
@@ -16,6 +16,7 @@ config BR2_PACKAGE_SPIDERMONKEY_JIT_ARCH_SUPPORTS
config BR2_PACKAGE_SPIDERMONKEY
bool "spidermonkey"
+ depends on BR2_HOST_GCC_AT_LEAST_4_9
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_PACKAGE_SPIDERMONKEY_ARCH_SUPPORTS
depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_9
@@ -43,5 +44,6 @@ comment "spidermonkey needs a glibc or musl toolchain with C++, wchar, dynamic l
!BR2_INSTALL_LIBSTDCPP || \
BR2_STATIC_LIBS || \
!BR2_TOOLCHAIN_HAS_THREADS_NPTL || \
+ !BR2_HOST_GCC_AT_LEAST_4_9 || \
!BR2_TOOLCHAIN_GCC_AT_LEAST_4_9 || \
!BR2_USE_WCHAR