aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Peter Korsgaard <peter@korsgaard.com>2015-11-18 23:03:42 +0100
committerGravatar Peter Korsgaard <peter@korsgaard.com>2015-11-18 23:03:42 +0100
commit551cdaf2d2ab1325f06bfa8814df43b586be3d5a (patch)
treeaf423968bacd3fcc146e5e0563b999e31253c503
parent34d081674ab8f0ffad84e5a18d3c67855826262f (diff)
downloadbuildroot-551cdaf2d2ab1325f06bfa8814df43b586be3d5a.tar.gz
buildroot-551cdaf2d2ab1325f06bfa8814df43b586be3d5a.tar.bz2
qt5base: use 'depends on' for directfb
This is the only package where we select directfb. Change it to use depends on to match what we do for the X11 backend. Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/qt5/qt5base/Config.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/package/qt5/qt5base/Config.in b/package/qt5/qt5base/Config.in
index 603df45766..7cadcb2b89 100644
--- a/package/qt5/qt5base/Config.in
+++ b/package/qt5/qt5base/Config.in
@@ -178,11 +178,10 @@ config BR2_PACKAGE_QT5BASE_LINUXFB
config BR2_PACKAGE_QT5BASE_DIRECTFB
bool "directfb support"
- select BR2_PACKAGE_DIRECTFB
- depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_5 # directfb
+ depends on BR2_PACKAGE_DIRECTFB
-comment "directfb needs a toolchain w/ gcc >= 4.5"
- depends on !BR2_TOOLCHAIN_GCC_AT_LEAST_4_5
+comment "directfb backend if directb is enabled"
+ depends on !BR2_PACKAGE_DIRECTFB
config BR2_PACKAGE_QT5BASE_XCB
bool "X.org XCB support"