aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGravatar Valentin Korenblit <valentinkorenblit@gmail.com>2019-04-13 10:45:55 +0200
committerGravatar Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2019-04-13 16:51:56 +0200
commit2a17fb6057eed2416e81cc138c885b1385fbff5d (patch)
tree8a7e404c2295b39460df2d8b45e9923644d55655
parent8b84b9016238cb28f71bebb7438c3c57e7fb7725 (diff)
downloadbuildroot-2a17fb6057eed2416e81cc138c885b1385fbff5d.tar.gz
buildroot-2a17fb6057eed2416e81cc138c885b1385fbff5d.tar.bz2
package/llvm: fix build with gcc < 5.1
Fixes: http://autobuild.buildroot.net/results/0c046a1b57a4f0b992333003d41062e1b256eb0d Signed-off-by: Valentin Korenblit <valentinkorenblit@gmail.com> [Arnout: add explanatory comment suggested by Romain] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
-rw-r--r--package/llvm/llvm.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/llvm/llvm.mk b/package/llvm/llvm.mk
index cd374d74b4..3c62285188 100644
--- a/package/llvm/llvm.mk
+++ b/package/llvm/llvm.mk
@@ -17,6 +17,13 @@ LLVM_INSTALL_STAGING = YES
HOST_LLVM_DEPENDENCIES = host-python
LLVM_DEPENDENCIES = host-llvm
+# LLVM >= 9.0 will soon require C++14 support, building llvm 8.x using a
+# toolchain using gcc < 5.1 gives an error but actually still works. Setting
+# this option makes it still build with gcc >= 4.8.
+# https://reviews.llvm.org/D57264
+HOST_LLVM_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+LLVM_CONF_OPTS += -DLLVM_TEMPORARILY_ALLOW_OLD_TOOLCHAIN=ON
+
# Don't build clang libcxx libcxxabi lldb compiler-rt lld polly as llvm subprojects
# This flag assumes that projects are checked out side-by-side and not nested
HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_PROJECTS=""