summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Ripard <maxime.ripard@free-electrons.com>2011-06-29 13:46:18 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2011-07-04 06:13:48 (GMT)
commitf1e4aac40ec1271aae5c056243cdc9e2b0b6f2bf (patch)
treec2aefb0f9e59bd75ababfdfa9a8d7591906fea94
parent90cdd7d925553c63fff3e208e8fd4a4e178603cf (diff)
downloadbuildroot-f1e4aac40ec1271aae5c056243cdc9e2b0b6f2bf.tar.gz
buildroot-f1e4aac40ec1271aae5c056243cdc9e2b0b6f2bf.tar.bz2
busybox: remove quirk for old unsupported versions
This code is no longer useful, since the oldest version supported by Builroot is 1.16. Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/busybox/busybox.mk11
1 files changed, 0 insertions, 11 deletions
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index b77880c..034801e 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -49,17 +49,6 @@ define BUSYBOX_SET_SYSKLOGD
endef
endif
-# id applet breaks on >=1.13.0 with old uclibc unless the bb pwd routines are used
-ifeq ($(BR2_BUSYBOX_VERSION_1_13_X)$(BR2_BUSYBOX_VERSION_1_14_X)$(BR2_UCLIBC_VERSION_0_9_29),yy)
-define BUSYBOX_SET_BB_PWD
- if grep -q 'CONFIG_ID=y' $(BUSYBOX_BUILD_CONFIG); \
- then \
- echo 'warning: CONFIG_ID needs BB_PWD_GRP with old uclibc, enabling' >&2;\
- $(SED) "s/^.*CONFIG_USE_BB_PWD_GRP.*/CONFIG_USE_BB_PWD_GRP=y/;" $(BUSYBOX_BUILD_CONFIG); \
- fi
-endef
-endif
-
ifeq ($(BR2_LARGEFILE),y)
define BUSYBOX_SET_LARGEFILE
$(call KCONFIG_ENABLE_OPT,CONFIG_LFS,$(BUSYBOX_BUILD_CONFIG))