summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-12-08 10:21:49 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2011-12-08 10:22:57 (GMT)
commitd6dfc2109c7149a795f7bda963a9a583685dec3f (patch)
tree1f1e45502b47cd5d5634dc14f869b1842c6610eb
parent713bb00aa2ab6da400766bc8683f6b95fbacdece (diff)
downloadbuildroot-d6dfc2109c7149a795f7bda963a9a583685dec3f.tar.gz
buildroot-d6dfc2109c7149a795f7bda963a9a583685dec3f.tar.bz2
transmission: gtk client needs locale support in toolchain
Otherwise configure errors out with: configure: error: "The gtk client cannot be built without nls support. Try adding either --enable-nls or --disable-gtk" Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/transmission/Config.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/transmission/Config.in b/package/transmission/Config.in
index 3fcf017..e7e9f66 100644
--- a/package/transmission/Config.in
+++ b/package/transmission/Config.in
@@ -36,10 +36,12 @@ config BR2_PACKAGE_TRANSMISSION_REMOTE
config BR2_PACKAGE_TRANSMISSION_GTK
bool "transmission-gtk"
- depends on BR2_PACKAGE_LIBGTK2
+ depends on BR2_PACKAGE_LIBGTK2 && BR2_ENABLE_LOCALE
help
Install transmission GTK-based GUI interface.
+comment "transmission-gtk requires a toolchain with locale support"
+ depends on BR2_PACKAGE_LIBGTK2 && !BR2_ENABLE_LOCALE
endif
comment "Transmission requires a toolchain with IPv6 support"