summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-11-09 20:57:37 (GMT)
committer Peter Korsgaard <peter@korsgaard.com>2013-11-10 08:14:24 (GMT)
commitaf616db359fd0811736821f23971094c6600f5bf (patch)
treea321f9d3ce995c7d7cb73474324089d6528ba9df
parentc74f17754a989b642ecc4b4a20af6e528bd5c8cd (diff)
downloadbuildroot-af616db359fd0811736821f23971094c6600f5bf.tar.gz
buildroot-af616db359fd0811736821f23971094c6600f5bf.tar.bz2
mplayer: disable for anything lower than ARMv5
Disable mplayer for anything lower than a v5 ARM core. The support is broken and it's kind of pointless anyway. Fixes: http://autobuild.buildroot.net/results/8f946e28b11b2ab1ba0d9688286c665488de0486/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
-rw-r--r--package/mplayer/Config.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/mplayer/Config.in b/package/mplayer/Config.in
index 7cee87d..b930cb5 100644
--- a/package/mplayer/Config.in
+++ b/package/mplayer/Config.in
@@ -3,6 +3,9 @@ config BR2_PACKAGE_MPLAYER
# Those architectures are not supported by MPlayer
depends on !(BR2_sh2 || BR2_sh2a || BR2_sh4a || BR2_sh4aeb \
|| BR2_microblaze || BR2_aarch64)
+ # Broken support for <ARMv5
+ depends on !(BR2_arm7tdmi || BR2_arm720t || BR2_arm920t \
+ || BR2_arm920t || BR2_arm922t || BR2_fa526 || BR2_strongarm)
depends on BR2_LARGEFILE
help
MPlayer is a movie player which runs on many systems and supports