summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-07-12 00:58:55 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2013-07-12 11:31:47 (GMT)
commit8da92a1c35c7327c49b2a96dc04d7fe80ae9bac6 (patch)
treef551057715d1d983bf3cb96b72cd4aeac199896b
parentbef0f4c818f4dcef2589e034ad02ffeec3cab1d3 (diff)
downloadbuildroot-8da92a1c35c7327c49b2a96dc04d7fe80ae9bac6.tar.gz
buildroot-8da92a1c35c7327c49b2a96dc04d7fe80ae9bac6.tar.bz2
nodejs: not supported on old ARM cores
nodejs needs the ARM blx instruction which is only supported in v5t+ cores (v5 ISA with thumb instructions). Disable it for lower cores. Fixes: http://autobuild.buildroot.net/results/89e/89ee5ba047a26a8c7a612d0285b08780b70efbd4/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/nodejs/Config.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/nodejs/Config.in b/package/nodejs/Config.in
index aa65c6f..fea3480 100644
--- a/package/nodejs/Config.in
+++ b/package/nodejs/Config.in
@@ -5,6 +5,8 @@ config BR2_PACKAGE_NODEJS
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_arm || BR2_i386 || BR2_x86_64
+ # ARM needs BLX, so v5t+
+ depends on !(BR2_arm7tdmi || BR2_arm720t || BR2_arm920t || BR2_arm922t || BR2_fa526)
# uses fork()
depends on BR2_USE_MMU
help