summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Claves <claves@budelmann-elektronik.com>2013-03-01 13:38:28 (GMT)
committer Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-07-31 11:49:32 (GMT)
commit61861a2ffbcc04bc641d0e42c659bcc810eee226 (patch)
treec2aef048a8761f6690cfb1b9ceae147a55686a5b
parentfc8b560d8a6948553aa6396b8f0b784809b2df3d (diff)
downloadbuildroot-61861a2ffbcc04bc641d0e42c659bcc810eee226.tar.gz
buildroot-61861a2ffbcc04bc641d0e42c659bcc810eee226.tar.bz2
libgpgme: new package
[Thomas: bump version, add --with-gpg-error-prefix and --with-libassuan-prefix options.] Signed-off-by: Philipp Claves <claves@budelmann-elektronik.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/Config.in1
-rw-r--r--package/libgpgme/Config.in11
-rw-r--r--package/libgpgme/libgpgme.mk23
3 files changed, 35 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index b6d6020..6171693 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -418,6 +418,7 @@ source "package/cryptodev/Config.in"
source "package/gnutls/Config.in"
source "package/libgcrypt/Config.in"
source "package/libgpg-error/Config.in"
+source "package/libgpgme/Config.in"
source "package/libassuan/Config.in"
source "package/libmcrypt/Config.in"
source "package/libmhash/Config.in"
diff --git a/package/libgpgme/Config.in b/package/libgpgme/Config.in
new file mode 100644
index 0000000..f97a3fe
--- /dev/null
+++ b/package/libgpgme/Config.in
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBGPGME
+ bool "libgpgme"
+ #gnupg is not needed to build, but at runtime.
+ select BR2_PACKAGE_GNUPG
+ select BR2_PACKAGE_LIBGPG_ERROR
+ select BR2_PACKAGE_LIBASSUAN
+ help
+ GnuPG Made Easy (GPGME) is a library designed to make access
+ to GnuPG easier for applications.
+
+ http://www.gnupg.org/related_software/gpgme/
diff --git a/package/libgpgme/libgpgme.mk b/package/libgpgme/libgpgme.mk
new file mode 100644
index 0000000..ee983df
--- /dev/null
+++ b/package/libgpgme/libgpgme.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# libgpgme
+#
+################################################################################
+
+LIBGPGME_VERSION = 1.4.2
+LIBGPGME_SITE = ftp://ftp.gnupg.org/gcrypt/gpgme/
+LIBGPGME_SOURCE = gpgme-$(LIBGPGME_VERSION).tar.bz2
+LIBGPGME_LICENSE = LGPLv2.1+
+LIBGPGME_LICENSE_FILES = COPYING.LESSER
+LIBGPGME_INSTALL_STAGING = YES
+
+# libgpgme, needs to know the gpg binary path on the target.
+LIBGPGME_CONF_OPT = --with-gpg=/usr/bin/gpg \
+ --with-gpg-error-prefix=$(STAGING_DIR)/usr \
+ --with-libassuan-prefix=$(STAGING_DIR)/usr \
+ --without-gpgsm \
+ --without-gpgconf \
+ --without-g13
+LIBGPGME_DEPENDENCIES = libassuan libgpg-error
+
+$(eval $(autotools-package))