summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-04 19:52:04 (GMT)
committer Thomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-05-07 19:28:33 (GMT)
commit4880edd506a2c629efa4ccf38f27f47d5d5d8804 (patch)
tree54c5ccec1648a4dc89256183aefe8f2cc00b84cd
parentb65e735291fe91ae97b976be211c3e04e9d05d23 (diff)
downloadbuildroot-4880edd506a2c629efa4ccf38f27f47d5d5d8804.tar.gz
buildroot-4880edd506a2c629efa4ccf38f27f47d5d5d8804.tar.bz2
libxcb: fix path to Python modules
When building libxcb, the variable XCBPROTO_XCBPYTHONDIR must point to the location where the Python modules needed to run the c_client.py program are installed. The path $(STAGING_DIR)/usr/lib/python2.6/site-packages was hardcoded. However, it doesn't work when the version of Python installed on the host is Python 2.5. Therefore, add a little bit of magic to compute the host Python version. We also verify that Python is available on the host, as we don't build it in Buildroot. Fixes bug #1531. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--package/x11r7/libxcb/libxcb.mk3
-rwxr-xr-xtoolchain/dependencies/dependencies.sh2
2 files changed, 3 insertions, 2 deletions
diff --git a/package/x11r7/libxcb/libxcb.mk b/package/x11r7/libxcb/libxcb.mk
index ec9843e..c8b70ea 100644
--- a/package/x11r7/libxcb/libxcb.mk
+++ b/package/x11r7/libxcb/libxcb.mk
@@ -13,7 +13,8 @@ LIBXCB_AUTORECONF = NO
LIBXCB_LIBTOOL_PATCH = NO
LIBXCB_DEPENDENCIES = host-libxslt pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
-LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python2.6/site-packages
+HOST_PYTHON_VERSION=$(shell python --version 2>&1 | sed 's/Python \(2\.[0-9]\)\..*/\1/')
+LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XCBPROTO_XCBPYTHONDIR=$(STAGING_DIR)/usr/lib/python$(HOST_PYTHON_VERSION)/site-packages
$(eval $(call AUTOTARGETS,package/x11r7,libxcb))
diff --git a/toolchain/dependencies/dependencies.sh b/toolchain/dependencies/dependencies.sh
index 013c1d5..923c76b 100755
--- a/toolchain/dependencies/dependencies.sh
+++ b/toolchain/dependencies/dependencies.sh
@@ -122,7 +122,7 @@ if ! $SHELL --version 2>&1 | grep -q '^GNU bash'; then
fi;
# Check that a few mandatory programs are installed
-for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio ; do
+for prog in awk bison flex msgfmt makeinfo patch gzip bzip2 perl tar wget cpio python ; do
if ! which $prog > /dev/null ; then
/bin/echo -e "\nYou must install '$prog' on your build machine";
if test $prog = "makeinfo" ; then