summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-04-29 10:29:31 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2013-04-29 20:56:13 (GMT)
commit331b14a2aede9259e5b0db20336a371ec223aff2 (patch)
tree07f2cf030a24c826b7e2ca53143ed6cfaf64f0c9
parent26406543db143b546eade6f61629c85a71208329 (diff)
downloadbuildroot-331b14a2aede9259e5b0db20336a371ec223aff2.tar.gz
buildroot-331b14a2aede9259e5b0db20336a371ec223aff2.tar.bz2
qt, php: selecting mysql requires depending on MMU
The mysql_client package is only available on architectures having a MMU, so all packages that are selecting mysql_client should depend on BR2_USE_MMU. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/php/Config.ext3
-rw-r--r--package/qt/Config.sql.in1
2 files changed, 4 insertions, 0 deletions
diff --git a/package/php/Config.ext b/package/php/Config.ext
index 2cf71d3..006d7dd 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -105,6 +105,7 @@ config BR2_PACKAGE_PHP_EXT_SQLITE_UTF8
config BR2_PACKAGE_PHP_EXT_MYSQL
bool "Mysql"
depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU # mysql
select BR2_PACKAGE_MYSQL_CLIENT
help
MySQL support
@@ -112,6 +113,7 @@ config BR2_PACKAGE_PHP_EXT_MYSQL
config BR2_PACKAGE_PHP_EXT_MYSQLI
bool "Mysqli"
depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU # mysql
select BR2_PACKAGE_MYSQL_CLIENT
select BR2_PACKAGE_PHP_EXT_MYSQL
help
@@ -127,6 +129,7 @@ if BR2_PACKAGE_PHP_EXT_PDO
config BR2_PACKAGE_PHP_EXT_PDO_MYSQL
bool "MySQL"
depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_USE_MMU # mysql
select BR2_PACKAGE_MYSQL_CLIENT
help
PDO driver for MySQL
diff --git a/package/qt/Config.sql.in b/package/qt/Config.sql.in
index eceb15d..04489c7 100644
--- a/package/qt/Config.sql.in
+++ b/package/qt/Config.sql.in
@@ -9,6 +9,7 @@ config BR2_PACKAGE_QT_MYSQL
select BR2_PACKAGE_MYSQL_CLIENT
select BR2_PACKAGE_NCURSES
select BR2_PACKAGE_READLINE
+ depends on BR2_USE_MMU # mysql
help
Build MySQL driver
If unsure, say n.