summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-01-24 21:28:47 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2012-01-24 21:28:47 (GMT)
commit21f39f524ff52e0649c88acf32fb78d3592fb3c8 (patch)
treea1eae31d2f6625af5de1d566b9c31690aef7cef9
parent16b17c9a15509f926579ced17285e9b38952b548 (diff)
downloadbuildroot-21f39f524ff52e0649c88acf32fb78d3592fb3c8.tar.gz
buildroot-21f39f524ff52e0649c88acf32fb78d3592fb3c8.tar.bz2
gdb: add 7.4, mark 7.1 as deprecated
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--toolchain/gdb/Config.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/toolchain/gdb/Config.in b/toolchain/gdb/Config.in
index 9868580..8501983 100644
--- a/toolchain/gdb/Config.in
+++ b/toolchain/gdb/Config.in
@@ -30,7 +30,7 @@ choice
prompt "GDB debugger Version"
default BR2_GDB_VERSION_6_6 if BR2_bfin
default BR2_GDB_VERSION_6_7_1_AVR32_2_1_5 if BR2_avr32
- default BR2_GDB_VERSION_7_3
+ default BR2_GDB_VERSION_7_4
depends on BR2_PACKAGE_GDB || BR2_PACKAGE_GDB_SERVER || BR2_PACKAGE_GDB_HOST
help
Select the version of gdb you wish to use.
@@ -58,6 +58,7 @@ choice
config BR2_GDB_VERSION_7_1
bool "gdb 7.1"
depends on !BR2_bfin
+ depends on BR2_DEPRECATED
depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
@@ -73,6 +74,12 @@ choice
depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
+ config BR2_GDB_VERSION_7_4
+ bool "gdb 7.4.x"
+ depends on !BR2_bfin
+ depends on BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ select BR2_PTHREAD_DEBUG if (BR2_TOOLCHAIN_BUILDROOT && !BR2_PTHREADS_NONE)
+
endchoice
comment "gdb 7.x support needs pthread debug support in toolchain"
@@ -88,3 +95,4 @@ config BR2_GDB_VERSION
default "7.1a" if BR2_GDB_VERSION_7_1
default "7.2a" if BR2_GDB_VERSION_7_2
default "7.3.1" if BR2_GDB_VERSION_7_3
+ default "7.4" if BR2_GDB_VERSION_7_4