summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-02-28 12:20:47 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2013-02-28 12:20:47 (GMT)
commit0e0e42176d4a46515aff577d9702d91208e27c5d (patch)
treed82b3bd3f62b772a23a7b19af023d64b15013b8f
parente4ee2811e30a952bf5a9c35b4d069c7c9b4c3bfe (diff)
downloadbuildroot-0e0e42176d4a46515aff577d9702d91208e27c5d.tar.gz
buildroot-0e0e42176d4a46515aff577d9702d91208e27c5d.tar.bz2
libgtk2: warn that directfb backend is deprecated
And will go away in the future, as discussed here: http://lists.busybox.net/pipermail/buildroot/2013-February/067977.html Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/libgtk2/Config.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/libgtk2/Config.in b/package/libgtk2/Config.in
index 3e8cf75..88f4cc1 100644
--- a/package/libgtk2/Config.in
+++ b/package/libgtk2/Config.in
@@ -29,3 +29,6 @@ config BR2_PACKAGE_LIBGTK2_DEMO
comment "libgtk2 requires a toolchain with WCHAR and C++ support"
depends on !BR2_USE_WCHAR || !BR2_INSTALL_LIBSTDCPP
+
+comment "WARNING: Libgtk2 directfb backend is deprecated"
+ depends on BR2_PACKAGE_LIBGTK2 && !BR2_PACKAGE_XORG7