summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-06-21 11:15:04 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2011-06-21 11:15:04 (GMT)
commit0a78829e0a0d781a95a040435e22ec0d155c59ca (patch)
tree558768b50936da5f9200be7a9508f480bb080e39
parente46df26e11a790da253de2d4c8ae99b4768b684a (diff)
downloadbuildroot-0a78829e0a0d781a95a040435e22ec0d155c59ca.tar.gz
buildroot-0a78829e0a0d781a95a040435e22ec0d155c59ca.tar.bz2
qt: QtDeclarative needs script support as well
Otherwise configure errors out with: Error: QtDeclarative was requested, but it can't be built due to QtScript or QtGui being disabled. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/qt/Config.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 214f140..ab231d9 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -380,6 +380,7 @@ config BR2_PACKAGE_QT_SCRIPTTOOLS
config BR2_PACKAGE_QT_DECLARATIVE
bool "Declarative module"
+ depends on BR2_PACKAGE_QT_SCRIPT
depends on BR2_PACKAGE_QT_GUI_MODULE
help
Build the Qt Declarative Module for qml support