summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2013-01-11 13:45:28 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2013-01-12 19:58:33 (GMT)
commit051058f52ae701928829b2304df4507892b44cfc (patch)
tree4a65373ff2b2f6a6a8e9cdf50dff9fca4133f04c
parent0ff2e73c058aac371247dca0336ad9caa590c389 (diff)
downloadbuildroot-051058f52ae701928829b2304df4507892b44cfc.tar.gz
buildroot-051058f52ae701928829b2304df4507892b44cfc.tar.bz2
libelementary: depends on libethumb
This was exposed because I still had an old libethumb in my staging directory so it was detected by configure, but because of the missing dependency it was still the (incompatible) version from before the 1.7.4 bump. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--package/efl/libelementary/libelementary.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/efl/libelementary/libelementary.mk b/package/efl/libelementary/libelementary.mk
index 81289ff..f63f0dc 100644
--- a/package/efl/libelementary/libelementary.mk
+++ b/package/efl/libelementary/libelementary.mk
@@ -18,4 +18,11 @@ LIBELEMENTARY_DEPENDENCIES = libeina libevas libecore libedje host-libedje \
LIBELEMENTARY_CONF_OPT = --with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
--with-eet-eet=$(HOST_DIR)/usr/bin/eet
+ifeq ($(BR2_PACKAGE_LIBETHUMB),y)
+LIBELEMENTARY_DEPENDENCIES += libethumb
+LIBELEMENTARY_CONF_OPT += --enable-ethumb
+else
+LIBELEMENTARY_CONF_OPT += --disable-ethumb
+endif
+
$(eval $(autotools-package))