summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-03-25 18:40:59 (GMT)
committer Peter Korsgaard <jacmet@sunsite.dk>2013-03-25 18:50:22 (GMT)
commit02c26700f4bb038ff5ec64570f8fc7f8b90250de (patch)
tree7556c5e8451ae87ac75c4e57e9af3094d9563c6a
parentaf9605d822e8712c2bd4d3cb585595c2fe6b41a6 (diff)
downloadbuildroot-02c26700f4bb038ff5ec64570f8fc7f8b90250de.tar.gz
buildroot-02c26700f4bb038ff5ec64570f8fc7f8b90250de.tar.bz2
toolchain: default to gcc 4.7.x
With 4.8.x released, it makes sense to update our default gcc version before 4.6.x becomes unmaintained. At the same time simplify the kconfig logic a bit. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
-rw-r--r--toolchain/gcc/Config.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 87d9cc1..f8cb82a 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -7,9 +7,9 @@ config BR2_GCC_NEEDS_MPC
choice
prompt "GCC compiler Version"
- default BR2_GCC_VERSION_4_6_X if !BR2_avr32 && !BR2_sparc_sparchfleon && !BR2_sparc_sparchfleonv8 && !BR2_sparc_sparcsfleon && !BR2_sparc_sparcsfleonv8
default BR2_GCC_VERSION_4_4_X if BR2_sparc_sparchfleon || BR2_sparc_sparchfleonv8 || BR2_sparc_sparcsfleon || BR2_sparc_sparcsfleonv8
default BR2_GCC_VERSION_4_2_2_AVR32_2_1_5 if BR2_avr32
+ default BR2_GCC_VERSION_4_7_X
help
Select the version of gcc you wish to use.